Using Cognos VM image to create/add a new dispatcher to the Cognos Cluster


We have Cognos installed on VMs and recently, due to increased demand, I was asked to add a new dispatcher to the cluster. We have heavily customized our Cognos environment and, in order to save time, I requested that the new VM be imaged from the existing dispatcher. When I opened the configuration on this new VM, I got CAM-CRP-1280 error but I also found a solution to remove some files and create a default cogstartup.xml file on your site. Thanks!

Now my question is that is it OK to modify the configuration of this new VM and add it to the existing Cognos cluster? Any concerns with adding a new VM that is an image of the another VM in the same cluster (though configuration settings will be updated)? I don’t think it is the industry best practice but it has the potential to save a lot of time in the future when we need to add a new dispatcher or even upgrade to the new version.

Thanks for any help you can provide on this matter.




We have a very similar setup and make use of VM cloning a lot. Not only for adding app servers to an existing environment but also to create entire new environments. We find it much simpler to modify a few config files rather than re-installing and re-configuring all servers.

There are very few gotchas - the most important thing when cloning entire environments is to export the config unencrypted prior to cloning. Alternately we’ve created “template” config files that we complete in a text editor and then deploy to the new servers.

Hope this is helpful, Daniel

Thanks for your reply Daniel!

I really liked the idea of creating templates and will certainly create them for the future. However, I already have the VM cloned from the existing server and my concerns are that since I did not export the config file, what should I be concerned with when configuring this VM.

When I received this VM and tried to open the Cognos Configuration, I got the CAM-CRP-1280. I found two articles that mentioned about renaming the cogstartup file and caserial file in the configuration folder, deleting/renaming the csk, encryptkeypair and signkeypair folders and renaming “freshness” file in the temp\cam folder to resolve the error. When I did that and started Cognos configuration, Cognos created a blank/default cogstartup and other files.

I can modify the configuration pretty quickly but once I do, will I be good to go? theoretically, I think, it should be fine but since this is the first time I am trying to use this approach, I want to be careful. Any suggestions?

Thanks and Regards,


Hi Sam.

You can always still export the configuration on the machine you used as “source” for the clone. Simply export the config unencrypted to “cogstartup.xml” and copy that file on to the new clone. When you open the Configuration Manager application it will read the unencrypted file, so all you should have to update is the “Environment” section - in particular you will need to update:

[ul][li]External Dispatcher URI[/li]
[li]Internal Dispatcher URI[/li]
[li]Dispatcher URI for external applications[/li][/ul]

They should all simply be “http://clonedServerName:9300/p2pd/servlet/dispatch

Once you’ve updated the config you should be able to test/save. Typically “Save” should cause new encryption keys to be retrieved from the content manager server. If this fails, you will probably need to clean out the following three directories first before saving the config (you will need to close the config manager application first, then reopen the unecrypted cogstartup.xml, then redo the config changes mentioned above, then try saving).

It can be a bit of a hassle, especially dealing with the encryption keys, but it’s minor compared with doing an install from scratch.

Finally, you probably want to go add the new app server into your gateway config so the gateway will allow connections even if only one of the two app-tiers is up and running.

Let me know if you’re still running into issues, Daniel

Hi Daniel,

Thanks for the detailed reply! I will first try to add it to the test environment to provide a proof of concept. Then one it is ok, we will add it to production.

I will try out these suggestions and post back the results.

Thanks for your quick response and help! Greatly appreciated!



Hi Daniel,

The app server after loading the cogstartup file from the source VM and modifying it worked! Thanks for your feedback and suggestions! The services started without any issues!

My next step is to install two Cognos 10 instances on the same VM to leverage the memory and processor capacity. Any experience/suggestion for that? I will post my question on this site (separate thread) if I run into any issues. It will be a week before I get to that anyways.

For anyone else in the same boat as mine, please see Daniel’s response. I also found the following article interesting (deals specifically with the error message that I mentioned in my initial question on this post) and had tried it before posting my question on this site. I think that one file mentioned in the IBM article - CaSerial file gets automatically created when the configuration app is started. But to be safe, I had deleted it earlier. This file has a reference to the server so it included a reference to the source VM.

Once again, Thanks for your help and advice. Greatly appreciated!