Unable to browse images during report building

Unable to browse images from report studio

IIS web server errors appear when trying to browse for images during report building.
Any of the following errors may appear:

HTTP 404.2 File / Page not found
Web server error: 405 Method Not Allowed
Web server error: 501 Not Implemented

When you want to insert an image into a report and you try to browse to the location (URL) where the image is located, an error message like the one below appears:

Web server error:
501 Not Implemented
To be able to browse images on a Web server, you must enable “Web-based Distributed Authoring and Versioning” (WebDAV) on your IIS Cognos Web server.

- IPlanet Web server does not support WebDAV
- Web authentication software such as Siteminder may be blocking - or not support - WebDAV. Ensure that WebDAV requests are being correctly processed.

Steps to Enable WebDav functionality:

If you are using an Apache Web server, configure WebDAV for your server. See the Apache documentation how to set it up.

If you are using Microsoft Internet Information Services (IIS), enable the Read and Directory Browsing properties for the URL you want to access:

1. Open the Control Panel and double-click Internet Services Manager
2. Right-click the directory that points to the folder containing the image you want to insert and click Properties. If no directory exists for the folder, create one and point it to the folder.
3. In the Virtual Directory or Directory tab, select the Read and Directory Browsing check boxes and click OK.

To confirm that WebDAV is configured correctly, use Internet Explorer as a WebDAV client:

1. In Internet Explorer, from the File menu, click Open
2. In the Open box, type the URL containing the images you want to browse.
3. Select the Open as a Web Folder check box.
4. Click OK

If the folder opens successfully and you see pictures, WebDAV is working.