Welcome to the new CogKnowHow.com!


If you have trouble logging in, reset your password via the login window
by clicking the 'Forgot Password' link.

RSV-SRV-0056 The Report Server process did not initialize properly

Any help is appreciated. We are receiving this error when scheduling reports to run. This is happening to about 80% of the scheduled reports.

RSV-SRV-0056 The Report Server process did not initialize properly

Here’s a little more from the log file on the server…

Failure CCL-SRV-0501 The BIBusTKServer process caught an unexpected exception. CCL-SRV-0501 The BIBusTKServer process caught an unexpected exception.CCLAssertErrorCCL_ASSERT(m_serv_reader == 0);
10.98.24.252:9300 4444 2010-10-20 07:15:28.278 -6 4780 RSVP 2241 1 Audit.RTUsage.RSVP Response Failure RSV-SRV-0056 The Report Server process did not initialize properly. Contact your Administrator.

Hi Sherie,

i have some additional questions.

  1. Which version are you using ?
  2. Did the report server work properly before?
  3. if i understand correctly when you run the report with the same credentials it works without a problem?
  4. which OS are you using windows, aix, linux?

thx
:wink:

We are using Cognos 8.4. Yes, the report server has worked properly before. We experienced this problem a couple months ago and had to add memory to the server because they were paging. This is no longer the issue and the problem is occurring again. Running the report creates the correct output, scheduling is when the error occurs.

We are using Windows 2003. Cognos response is to regenerate the crypto keys which is what we will probably try next.

i’m also thinking in the security direction…

Is the “IBM Cognos 8” service started by a service account? if so is this account member of the local administrators group?? It might have something to do with the lack of permission to read/write to a directory on this server.

You can also try to renew the credentials of the previous scheduled report (if you are the user who is set as property “run as the owner”

When you save a schedule, your AccessNet password is saved with it. If you change your password (as you will need to do periodically), the new password does not automatically replace the credentials previously saved with your schedule. As a result, when the schedule attempts to run a report, Cognos will refuse the request since the password no longer matches the one on record.
To fix this, go into ‘My Preferences’ (the little person icon at the top of the viewer screen) and select the ‘Personal’ tab. In the ‘Credentials’ section in the middle of the screen, click on ‘Renew the credentials’.

or create a new schedule with this report and slect your account as “run as owner” option.

I am getting this same error and log message, but it occurs for any report that is run in the background. Schedules, Save Report, deliver by email. Basically anything that’s not run now. Could this be related to something other than security on the schedule? Perhaps space on the content store db machine?

did you enable extra logging /tracing for cognos?

if so do the following:

[ul][li]Remove / rename the ipclientconfig.xml[/li]
[li]Or update the ipfclientconig.xml so it contains proper syntax if you require the file for tracing.[/li]
[li]Restart service after completing the above.[/li][/ul]
.

do this on every cognos server… :wink: