Oracle "Fetch Buffer Size" in Cognos Transformer 8.4

Hey there - does anyone know what is alternative in Cognos Transformer 8.4 for older “Fetch Buffer Size”? Looks like Transformer doesn’t use those options anymore within .INI file where that parameter was configured in the past. I have very slow performance when file writing to the disk (building temp file by exporting result from Oracle), therefore I’m looking for way to control/tune Oracle fetch buffer or in another word increase row limit per fetch. I have pretty powerful (I think) Cognos hardware for this Transformer only server: 2xQuadCore with 16GB of RAM and 6x300 HD with RAID 0. Any help on tuning model would be a great help!


i have transformer 8.4 installed and a cogdmor.ini file in de c8\bin directory just like in series 7.

; The entry ‘Fetch Number of Rows’ is used to determine how many rows to fetch
; per fetch operation. Increasing this number can provide better performance
; on some systems. Note that the OCI currently limits this number to 32767.
; Also note that numbers larger than 100 may actually degrade performance on
; some systems.
; The entry ‘Fetch Buffer Size’ is used to determine the size of buffer to
; use when fetching. Larger values can provide better performance on
; some systems. Note that on 16bit Windows platforms, this is restricted
; to approximately 64k.
; If both ‘Fetch Buffer Size’ and ‘Fetch Number of Rows’ are set, the latter
; will take precedence and the former will be ignored.
; By default, the buffer size used is 2048 bytes, to change this default,
; uncomment one of the following entries and set it accordingly.
;Fetch Buffer Size=2048
Fetch Number of Rows=1200

still works fine. ;D

Are you sure it’s working for you? I changed it and nothing different happened. I know that all INI files starting with 8.3 were replaced with XML files, only for S7 Bridge Transformer uses INI file. Also, I looked in TR documentation and not a single word about cogdmor.ini, so I’m confuse why those files even there… ???

I think you are right Alex,

I you have Transformer versions older than 8.3:

Add the following line to the \bin\Cogdmor.ini file:
Fetch Number of Rows=10 to 1000 or so

I you have Transformer 8.3 and above:

If the source is an IQD against Oracle, Transformer 8.3 and above uses the “Series 7” Gateway. The setting “Fetch Number of Rows=1000” must to be set in the cogdmor.ini, in the Series 7 Gateways directory:

To which transformer xml files are you referring to Alex?

Thanks CognosGirl for the reply!
I can’t use either of those options as I’m not using IQDs anymore: my source are FM packages and reports (glad to leverage new technology). Therefore I’m looking for a way to tune those sources as it was available for us with IQDs. Hope this clear now…


Hello, have anyone find solution to change these settings when using FM Packages? I have previously used series 7 iqd’s and Oracle. In those days I used cogdmor.ini to change “Fetch number of rows” to speed up some cube data loads.

Now I use cognos 10 Transformer with Framework Manager Packages and MS SQL Server. There is one dimension load in Transformer that is very slow. It takes 2-3 hours to load 400 000 rows into cube and 1-2 min to excecute the select statement in SQL Server Management Studio. I believe Fatch buffer size could be one problem that is slowing down Transformers data load.

Unfortunately all help from IBM support didn’t bring a real good performance, no matter what I changed with transformer config. If network pipe is small, no matter what you do on TR side, it won’t push DB side faster. At least that was my experience after many, many tries to optimize Oracle performance. However, it did improved performance after migration to Cognos 10, but DB side still a bit slow, but local processes works great now, so overall it’s faster, if you know what I mean. ::slight_smile:

Good luck with your attempts, share your experience, if you can.

If your using FM packages look to \configuration\CQEconfig.xml tweaks.


Yeah Grim, that is all great for FM tuning, but I think you’re missing core of our question/concern here: if we’re using FM as a source for transformer model, we can’t modify cogdmor.ini file to implement performance changes for DB (in my example Oracle), as cogdmor.ini uses only by IQDs, not FM. But don’t take me wrong, I appreciate your effort here. :wink:

Thanks for the info. My problem haven’t been solved but it have been narrowed. Now I believe fetch buffer size is not causing the problem.

I saved the data to csv file and tried to load it from there but still the load is slow. Whats interesting is that if Transformers Status window (records counter when building cube or generating categories) is correct the load is very fast till 250000 records. And after that its very slow (just 1000 records per minute). Behaviour is the same also when loading directly from database, about 250000 fast and then extremely slow. There is plenty of memory available on the server but transformer just uses about 320000k (and 25% of CPU).

I have tried to change some Transformer cogtr.xml settings but none of them haven’t had any impact to the cube build (although I’m not quite sure how to adjust the settings).

Theka - now you’re talking about internal processes slowness. Fetch buffer size property set for external data over network (Oracle, SQL Server, etc.), not for local process as you described here. Did you try to run update another time? What about system processes that runs on background at that time such as antivirus or any other scan?

Also, after 250k record, process can start build some complex category, which may cause slowness. Check log file after completion and see what log says about that time, then you can troubleshoot that part.

Hope that helps a little more… :slight_smile: