Invalid Dispatcher URI while setting up External data - Framework Manager import

I’m having a problem configurating External data - Framework Manager import.
When I click the Green Checkmark I receive the following message:

Invalid Dispatcher URI.

This is the Dispatcher URI: http://w3cc02:9300/p2pd/servlet/dispatch

Can anyone give me some tips?


Hi Frank,

how many servers do you have in your Cognos configuration? Is the BI server installed on the same server (w3cc02) as well? or do you have a multi server installation?

We have 2 servers, but as far as I know the BI server is installed on the same server.


To exclude a typo paste the dispatcher url http://w3cc02:9300/p2pd/servlet/dispatch in internet explorer on the controller server. You should get a unformatted Cognos 8 login screen. This means the dispatcher URL is correct. Check in the internet setting if you added the server w3cc02 to the trusted websites.

If you get an xml screen or error we can go from there.

Ok, I’m a little bit futher now.
The Controller configuration now works fine. “Verification Succeeded”.
The url works fine on both the server and client.

I now having a new problem.
When I start Controller, select a database and login, then choose “Transfer” -> “External Data” -> “Define Import Specification”.
On the tab “General” I select Framework Manager as the source and then click on “Model Name” I receive the Following message:
Failed to connect or login to Cognos 8.

What should I do next?


Hi Frank,

controller tries to connect to the Cognos Content store. It uses the gateway URL to login and find the published framework packages.

so there are 2 options:

  1. the gateway url defined in the Cognos configuration manager or controller administration is wrong
  2. the authentication fails.

i guess the option is the problem. Do you use SSO single signon and do you use native or cognos 8 authentication. You can find this setting in the controller administration configuration.

I use the Native authentication method and the singleSignOnOption.
The test function on the Content Store works fine.

i agree with Guru. :wink:

If the gateway URL you configured in cognos connection is working well in IE, then the login or authentiation is giving you a problem.

Try to disable the SSO option and login again. See if you get more clear error messages in the cogserver.log and the event viewer on both server.

Also examine the security “translation” table in controller - security. Here you attach the native security to the Cognos 8 security. The native security works fine but if you want to get data out of the BI portal, it uses the user ID in that secuity table to access to the BI portal via the gateway URL.

I had the same problem - before I installed SOAP Toolkit 3.0

Check this link: