Define Contents - Tuple function not working?

Hi To all again,

1- I have this report that is made of a crossTab

2- One of the columns is in fact a Data Item calculating a certain expressions

3- That Data Item works fine, the thing is that it is displaying the result on all of the others lines as well but i only need the result for the FIRST line. So i DEFINE CONTENT for all of the cells i don’t want to display that same information.

4- Only, i need to have another calculation on the SECOND LINE for that same column, for this i DEFINE content and decide to “Override Default Text” and then in the SOURCE TYPE propertie, i change it to “Report Expression” for that specific cell.

5- I try to use the TUPLE function but generates an error message. I also cannot see the TUPLE function listed under the FUNCTIONS tab of the “Report Expression” window.

I then tried to put the following expression (1-1) for testing only and this worked as expected and display 0 :
I mean this expression inside the cell i have decide to “DEFINE CONTENT” works, but when i try to use more complex expressions like using the TUPLe function it does not work ???

Is it normal that the TUPLE function is not supported in this DEFINE CONTENT context ?

Thanks !

Which version are you using?

tuple syntax has been changed from 8.2. Some tuple functions do not work anymore after the upgrade.


1- I am using Report Studio 8.4

2- I use the following expression in 3 other Data Items in my report and it is working:
tuple ( [CURRENT PERIOD]; [Sales] ) - tuple ( [PREV YEAR CURRENT PERIOD] ; [Sales] )

3- The thing that i am using the same logic but with 3 other Data Items that i am trying to then insert in specific cells of my crossTab and that is not working.


Thanks !

I have found it safer to use singletons for exceptions like these.

  1. define content
  2. unlock the crosstab
    3 drag a singleton into your cell on row 2
  3. let the singleton use another query. Means you have to copy slicer etc.