Crosstab: dimensions on the edge are inconsistent

Hi all,

I’m having a crosstab report with

  • rows: productgroup
  • nested rows: producttype
  • columns: months
  • measures
  1. [Products]: total # of products (can be aggregated over producttypes, productgroups)
  2. [Active Products]: total # of active product. For the atomic products, we know whether it is an active product (1) or not (0); these values can again be aggregated over producttypes, productgroups

Basically, the crosstab does not reflect any atomic data since the producttype (lowest level of product detail) will contain aggregates of the underlying products.

Now, the purpose is to have an average for each productgroup that is based upon the atomic product values and NOT on the producttype aggregates.

Therefore, I had tried following aggregate calculation::
total([Active Products] within detail [ProductType]) / total([Products] within detail [[ProductType])

However, when executing the report, I run into following error:
“The dimensions on the edge are inconsistent. The dimension of valueSet=“3” differs from the dimension of sibling edgeGroups.”

When I only take the nominator/denominator of the ratio, i.e. total([Active Products] within detail [ProductType]) OR total([Products] within detail [[ProductType]), I get the expected values for the nominator/denominator… However, when I create 2 distinct data items - each one separately containing the nominator & denominator - and afterwards take the ratio of these individual calculation, this did not work either…

I’m a bit lost so thanks to keep me posted!


Good Question,

I understand the error, because u got an unbalanced category tree.
Anyway to solve this i think its just testing things out.

I wanted to summarize detail as well, which is not orginally in the crosstab.
Anyway u can make a new data item (say Activeproducts1) with:
Active products =1
A new data item: (Activeproducts1 / (total(products)))

Drag this item in the crosstab - Summarize it for total and hide it…

Or make sections of product (so u skip 1 lvl) but this is probably not what u want.