Content store configuration


I installed Cognos Planning Server 8.4.1 (database:MS SQL 2005). I created database in MS SQL, I deleted and recreated a Content Store in IBM Cognos Configuration (with MS SQL database) ((I was given the right username and password on it))

But when I test it in IBM Cognos Configuration/Content Store it failed with errors:

[ ERROR ] The database connection failed.
[ ERROR ] Content Manager is unable to access the content store. Verify your database connection parameters,
and then contact your database administrator for assistance.

Please help me and answer me as soon as possible!



generally it is one of these things:

  1. type mismatch in the Cognos configuration manager (servername, port, user and password)
    test if you can reach the SQL database server.
  2. firewall between the Cognos application server and database server

for the Planning Store you need to install the SQL 2005 client (CD 2) as well. Planning Content store connection is made with an ODBC connection. The Cognos content store is made with JDBC. :-[

Hmm, if you are using SQL Server authentication to the content store database, try making sure that Mixed Mode authentication is actually enabled in SQL Server.

Where you would expect that it would prevent you from creating SQL auth accounts if its not enabled, it instead lets you create the accounts without complaining.

To check, go to the server node in SQL Server management studio, right click the server, select properties and check under the security section.

Please let us know how you get on.


Thank you the supporting! It was successfully soluted. The problem was a little adjusment in MS SQL: TCP/IP protokoll was disabled.
So it’s ok, but I have a new problem… :frowning:
(Sorry, I install Cognos Planning first time)

"There was a problem logging on. Please ensure you can access Cognos Connection using the Gateway URI specified in Cognos Connection. "
I’ve found a site about this:

I tried all (I referenced in place of localhost the name of the server, IP-adress also) but the problem is the same. I cann’t log in the Analyst. In the Internet Explorer I can load the IBM Cognos Administrationt (so I think the IIS is ok).
From IBM Cognos Connection I can start the services. Sg is missing to log in Analyst but I dont know what. Can you help me?

if you copy the gateway URL from Cognos configuration and this URL works in your browser than it is probably not webserver related…
This URL in the configuration manager is for the client tools to start the login script cognos.cgi or cognosisapi.dll

i have seen this message before when the analyst (rtm) version was not the same as the planning server (FP1)…
after installing the same version it worked without changing the configuration manager…

hope this helps

Thank you your answer!

My problem was casused by my very stupid decision. I configured in the IIS-t with cognos841, and in the IBM Cognos Configuration it was related on cognos8…
I can go on! :slight_smile: THank You!