Command line build of cubes not working with AD signon

Hi -
I have reviewed all the documents that tell me how to create a .bat file to build Transformer cubes without user intervention. Let me preface this with I have worked in the cognos products for quite some time (since 1999) and I have not ran into this issue yet.

We are running transformer 8.4, we use Active Directory to sign on (to this particular set of data). I have created a sign on with my AD account with the exact same letters and casing, checked “set as auto logon” (even created one for the data source sign on with the same information) and made sure the namespace is AD.

I built a simple little .bat file to just open (since building wasn’t working) to see if the sign on would not show … I have had no luck. Below you will find the last one I tried … I even tried the switch of -l and telling it my signon … still didn’t work. I cannot even open Transformer (without a .bat file) without it asking me for a signon. Granted we have two different signons (Active Directory and Infinium based security for specific data. The data I am after is on the AD side)

cd “c:\program files\cognos\c8\bin”

cogtr -nologo -p"\cmhcogapp01\d$\Transformer Models\step by step transformer administration.pyj"

This does open Transformer but waits for me to click OK for the AD sign-on.

Can anyone help?

further note: I did not have this issue with any other Transformer version. I have this issue only with the new sign-on through cognos portal. when it was a stand-alone product, I had no issue.

try to use -n1 (instead of -n alone) to supress trnsfrmr splash launch screen to build the cube after you have saved the mdl/pyj with the Cognos security provider signon userID and password. This can be done when the signon dialog is opened.

u sure its not a database signon?

We did have the same issue… tried everything in the book… but the prompt kept popping-up. :’(

At the end i installed a new transformer instance (and a new configuration manager). In this configuration manager i pointed to a non SSO gateway url.
in the IIS webserver i configured cognosisapi.dll for SSO and the cognos.cgi for basic signon (userid/password)

At least i can run cubes now, but still no SSO…

Then u can better use a database signon and auto script that