Welcome to the new CogKnowHow.com!


If you have trouble logging in, reset your password via the login window
by clicking the 'Forgot Password' link.

Cognos planning login issue HTTP Error 401.1 - Unauthorized


#1

Product:

Cognos Planning 10.1.1 fix pack 3
Windows 2008 R2 Server
Oracle Database

Symptom:
User get login dialog from Windows when they start Cognos Planning Analyst, or try to surf to the Cognos Connection page for Cognos Planning installation.
When they enter name and password, they are prompted with the same login dialog as before.

If you change the Internet Option - Advance - Enable Integrated Windows Authentication from checked (active) to blank (not used) and restart IE, then it works to come into the Cognos BI portal. Then it is not Cognos BI that is wrong, it is something with Windows IIS.

Error message if you press cancel:
server Error in Application "COGNOS/IBMPLAN/CGI-BIN"
HTTP Error 401.1 - Unauthorized
You do not have permission to view this directory or page using the credentials that you supplied.
WindowsAuthentication
AuthenticateRequest
....

In Cogplanningerrorlog.csv file you can find entries like this that tell you that the Cognos Planning server have been rebooted.
2014-12-16 02:06:12.851 UTC +60 epPlanningService 10.1.4074.0 default Poller.cpp PollUntilCredentialPathIsValid 579 epPlanningService::default::Poller.cpp::PollUntilCredentialPathIsValid::579 0 Credential Path in Content Manager is invalid. Jobs and Macros will not run until it is reset. Please open the Contributor Admin Console and reset the Credential Path.


Solution:
In a multiserver installation, where the Cognos Planning Gateway is located on a separate server from the Cognos Planning Content Manager and the Cognos Planning Job Servers, the restart of the Cognos Planning Gateway server was the solution.

The Cognos Planning Gateway (that run under IIS) was not working with authentication as it should, even do it looks like in IIS Manager that the integrated authentication is turned on for the correct folders.
During the night the Windows servers was restarted to apply a software update, but something have gone wrong on the IIS server, and therefore making the Cognos gateway not allow you to login.

Restart of the Cognos BI and Planning services, did not help, you had restart the physical Cognos Planning gateway server. Then probably the Windows update made it self correct and the SSO login is working.

www.cogknowhow.com