Welcome to the new CogKnowHow.com!


If you have trouble logging in, reset your password via the login window
by clicking the 'Forgot Password' link.

Cognos 10.2.1& Apache 2.2.15


#1

Buenas Tardes developers !

Estoy terminando de configurar IBM Cognos 10.2.1 en el servidor de Apache 2.2.15 ( Red Hat 6.5)

Ya tengo levantado el servicio de IBM Cognos , tal como lo muestran las imagenes :

Luego modifique el archivo httpd.confg del apache agregando estas directivas para el modulo de cognos :

LoadModule cognos_module "/opt/ibm/cognos/c10_64/cgi-bin/lib64/mod2_2_cognos.so"

CGIBinDir “/opt/ibm/cognos/c10_64/cgi-bin”>

#
#Options FollowSymLinks
#AllowOverride All
#
ScriptAlias /ibmcognos/cgi-bin/ "/opt/ibm/cognos/c10_64/cgi-bin/"
Alias /ibmcognos “/opt/ibm/cognos/c10_64/webcontent”
<Directory “/opt/ibm/cognos/c10_64/cgi-bin”>
AllowOverride FileInfo
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
SetHandler cgi-script
Order allow,deny
Allow from all

<Directory “/opt/ibm/cognos/c10_64/webcontent”>
Options FollowSymLinks
AllowOverride FileInfo
Order allow,deny
Allow from all

<Location /ibmcognos/cgi-bin/cognos_module>
SetHandler cognos-handler
Order allow,deny
Allow from all

<Location /ibmcognos/cgi-bin/diag_cognos_module>
SetHandler cognos-handler
Order allow,deny
Allow from all

Y al iniciar el servicio httpd (Apache) muestra el siguiente error

Luego se realizaron las siguientes acciones:

  • Se comento la primera linea : #LoadModule cognos_module “/opt/ibm/cognos/c10_64/cgi-bin/lib64/mod2_2_cognos.so”
  • Se ejecuto el comando : ./copyGateMod.sh 64bit
  • Se levanto el servicio httpd (Apache) - OK
    E igual no levanta cognos (ver imagen).

Ya he intentado diferentes caminos y formas y no llego a levantar el servicio.

Necesito de su gran apoyo para poder desplegar IBM Cognos 10.2.1 en el servidor de apache

De antemano muchas gracias
Saludos
Luis Sánchez