Cognos 10.1 Installation - 64 bits vs 32 bits && Content Store

I’m installing Cognos on my machine to make an study and some research about it. I installed the Content Database that comes with the Server Installer but when starting Cognos I get an error (just says ERROR) when “Starting IBM Cognos Content Database”.

I have the feeling that it didn’t install the “Content Database” even I checked it during the installation. Has anyone installed Cognos on one computer as I’m trying? I’ve been blocked at this same point for 2 days :frowning:

Here my configuration of the Content Store:

Server: localhost:1527
User ID/Password: ****
Database name: cm 

Thank you very much!!

On what platform (Windows, Linux)?
Have you tried an uninstall/reinstall?

hello Ana,

do you still have this problem?

The content store out of the box should install when you check it.
Is the port 1527 used by another application on you computer? like Oracle listner?

Sorry, I was checking the topic for a couple of days and as I didn’t receive responses, just reinstalled it with SQL Server 2008 :slight_smile:

Now I’m having another problem… And REALLY dont know how to continue…

I’ve the Content Manager set up correctly. I’ve the JAVA_HOME set to “installation_dir\jre\bin\6.0”, but when I start the service, it keeps on trying to start the JVM for maximum of times, and then throws the error: CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos 8 service in the time allotted

I’ve found this thread on IBM web page but still I couldn’t solve it…

It is exactly my case, but with the exception that I’d everything correctly configured… I went to Control Panel, to JAVA and there’s only a 32 bit version installed… I don’t really understand how they’re supposed to interact (32 and 64 bit extensions), I dont know if I should install a latest and just leave JAVA_HOME set to the other path… please… help!!

Ok I finally solved, and I’m gonna post the reply just in case someone needs it on the future.

My PC is Windows 7 (64bits) and I had JRE and JDK 7 installed on my computer (also several JDK and JRE 6 updates) I had the feeling that there was the problem, my Cognos Installation wasn’t being able to launch de JVM. So, the solution:

  1. Uninstalled ALL the installations of java on my machine (Add/Delete programs in Control Panel)
  2. Deleted JAVA_HOME defined
  3. Unistalled Cognos
  4. Rebooted the PC

Everything is fine now :slight_smile: So for those who can’t start Cognos Service, booting keeps trying to Launch JVM, and finally get the error “CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos 8 service in the time allotted” try it. It worked for me.