Analysis Studio Shows the Wrong Currency Symbol

Analysis Studio Shows the Wrong Currency Symbol

When published to IBM Cognos 8 Analysis Studio, PowerCubes show a default currency rather than the currency associated with the locale of your servers and PCs. For example, GBP (£) is shown as $.

To resolve this problem, you can do one of the following:
Create a currency table when you prepare your model in Transformer and embed a default currency symbol into the resulting PowerCubes, based on the system locale used by your Transformer computer.
For PowerCubes that do not contain an embedded currency table, set the fallbackCurrency parameter as the default currency.

Steps to Create a Currency Table in Transformer
In Transformer, from the File menu, click Currency Table and click OK.
Right-click each currency measure and click Allow currency conversion.
This default currency table does not include currency information for any locales other than your running locale. Also, you cannot convert to a different currency while working in Analysis Studio.

Step to Set fallbackCurrency as the Default Currency
Define a default currency by setting the fallbackCurrency parameter in the installation_location\configuration\qfs_config.xml file to GBP (Great Britain Pounds) or to an alternative currency code as listed in the installation_location\bin\ccli18nrescr_xx.xml file.
Here is an example.
<!-- execution layer providers-->
<provider name="PowerCubeODP" libraryName="pcodp"connectionCode="PC">
... <providerDetails>
<!-- Max depth of nested calculated members within a query. -->
<parameter name="maxCalculatedMemberNestingDepth"value="30"/>
<!-- Normalize yen/won currency symbols - set to "false" to disable -->
<parameter name="normalizeYenWon" value="true"/>
<!-- Fallback currency for cubes with no default currency specified - set to USD, EUR etc. -->
<parameter name="fallbackCurrency" value="USD"/>